Jump to content
Kent Gissing

Why is it so difficult to drive?

Recommended Posts

Something I really hate when driving any car in this game is the fact that every once in a while, the game will just randomly give you a boost and you will end up wrecking the car against a wall or a tree. Or, which has happened to me frequently, the game will bounce you several meters back on the road and you have that moment of being temporarily disoriented and the turn you had just begun to execute now leads you straight into a barrier.

These things seem to happen most often in cities, probably has something to do with loading and rendering, but it still makes driving extremely hazardous if you want to keep the car which you have spent hours and hours to build and maintain, as the cars are extremely fragile. Just now I had a Volga in pristine condition, I snail-paced myself past barriers in Elektro and then suddenly WOOOSH, a sudden boost straight into a block of concrete, car ruined and everything is going to have to be collected again. It's getting to that point where cars are just goals in and of themselves; get the car, park it in a tent and have it collect dust while you enjoy the achievment, but actually drive it at your own peril.

What I want to know is, is it a known bug that others are experiencing too or is it something that just happens to me? I have a private server where I have an unnaturally fast day-night cycle, but other than that, I have made no particular changes to any default settings.

  • Beans 1

Share this post


Link to post
Share on other sites

it is a known behavior unfortunatly. I repaired 9 cars since beta and crashed 3 because of these kind of lags. And I'm pretty sure everyone else that drove a car experienced these lags at some points.

 

My understanding of the issue is that cars are managed on server side in SA (instead of arma/mod where they were managed client side). That means any desync between client and server could cause this.

So if you have a slight internet lag, server will continue to move the car forward, but client will freeze (as it can't reach the server for few seconds), and when the client resync with server, your car will be teleported forward (may be in a tree or a wall if your unlucky..)

I confirm this happens a lot more in large city, or near camps, probably because the server have more objects to handle and is more likely to have performances drop.

 

That said (and if I'm right of course), it will probably be a very difficult issue to adress, because this is not just cars that needs few improvement, but the whole client/server sync layer that must be optimized, and server performances more globally.

That sadly makes me beleive we will never have working helicopters in SA, at least if they are managed the same way cars are today... 

  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, matiman said:

it is a known behavior unfortunatly. I repaired 9 cars since beta and crashed 3 because of these kind of lags. And I'm pretty sure everyone else that drove a car experienced these lags at some points.

 

My understanding of the issue is that cars are managed on server side in SA (instead of arma/mod where they were managed client side). That means any desync between client and server could cause this.

So if you have a slight internet lag, server will continue to move the car forward, but client will freeze (as it can't reach the server for few seconds), and when the client resync with server, your car will be teleported forward (may be in a tree or a wall if your unlucky..)

I confirm this happens a lot more in large city, or near camps, probably because the server have more objects to handle and is more likely to have performances drop.

 

That said (and if I'm right of course), it will probably be a very difficult issue to adress, because this is not just cars that needs few improvement, but the whole client/server sync layer that must be optimized, and server performances more globally.

That sadly makes me beleive we will never have working helicopters in SA, at least if they are managed the same way cars are today... 

I can confirm something like this.  I had just left Electro heading east and I decided to open it up.  I was doing about 100 km/h when I froze for a couple of seconds, heard a clunk and got the "you are dead".  Lost a lot of stuff but oh well.  Start again and will not drive so fast until they fix, if they are able to fix, this

Share this post


Link to post
Share on other sites

Patch 1.01 has better driving Performance than 1.02!

 

With 1.00 and 1.01 I never crashed a car! NEVER!!!

 

And 3 days after 1.02 I was stop 10-12 meters in front of a closed industrial gate and got instant lag.

One second later I hear two times crahsounds and my car stands inside the gate!

Ruined radiator, hood, wheels and battery. 😞

Share this post


Link to post
Share on other sites
22 hours ago, matiman said:

So if you have a slight internet lag, server will continue to move the car forward, but client will freeze (as it can't reach the server for few seconds), and when the client resync with server, your car will be teleported forward (may be in a tree or a wall if your unlucky..)

That would be a possible reason. However, I am running my own server on the same PC I use to play. And no, it is actually a closed server, so for all intents and purposes it is only me in that world. The intent is for me to be able to use my own server environment as sort of a test realm for myself when it comes to things like building bases or learning to drive cars without running the risk of being sniped by some PvP jagoff with a scope. ^^ But yeah, so lag is not really an issue here, unless there is some necessary data being transmitted from my server to Steam and then back to my PC again.

Share this post


Link to post
Share on other sites
4 minutes ago, Kent Gissing said:

But yeah, so lag is not really an issue here, unless there is some necessary data being transmitted from my server to Steam and then back to my PC again.

Internet lag is a possible reason for client/server desync, but I supposed you could have same kind of desync with performances drop on server side (that could explain that it happens more often in large cities).

Share this post


Link to post
Share on other sites

Still things work quite well in Arma 3. Even if this is more demanding you would think they would have it fixed by now. After all they have had many years to solve the issue....

  • Beans 1

Share this post


Link to post
Share on other sites

This is the sharp end of how BI has failed to invest enough in the game. It's just a joke that in 2019 you can't drive a car in a computer game.

Beta my ass.

  • Beans 1

Share this post


Link to post
Share on other sites
7 hours ago, Mookie (original) said:

This is the sharp end of how BI has failed to invest enough in the game. It's just a joke that in 2019 you can't drive a car in a computer game.

Automobiles first introduced to DayZ in 2014, still flying into the sky and suffering undriveable lag or desync in 2019.

For some reason I didn't have any unreasonable problems in ARMA 3 even sliding my pickup through cities at up to 150, 200 km/h or however fast it goes on the high-pop KOTH servers.

But DayZ SA the vehicles seem almost unfixable? 


(Of course sometimes ARMA 3 has its small issues too)

 

Share this post


Link to post
Share on other sites

Lol, just had another absurd close call.

Drove a LADA to the town of Krasnostav, made it through the city without much incident, then just as I was about to exit on the other side of town I figured I would run down a zombie because he was more or less in the way. Well, the Zombie remained standing up and clipped through the car unharmed, and I was like "Uh-oh"... if you drive a car straight through a frozen zombie and he just passes through, then you know what's about to happen. And true enough, just as I figured, the next moment the game suddenly warp-jumps me and the car all the way back (!!) to a point on the road before we even had entered the town, it was like going through a hyperspace tunnel without all the fancy effects. XD I slammed down on the brakes hard and luckily, this time I managed to come to a complete stop without crashing into anything. But my heart was racing almost as much as if I had been in a PvP skirmish.

I think this thread should just be about people talking about their close calls. You just kind of have to laugh at it at this point. ^^

  • Haha 1

Share this post


Link to post
Share on other sites

As stated in Arma3 devblogs and interviews a large part of the Arma team is now working on the enfusion engine ( the rest seems to work and support Vigor instead of DayZ). They further said that we will not see a new Arma title in the new future because of the new tech that will be used in all BI future games ( Enfusion) does not meet their standarts by now !!

This engine is simply far away from being finished and even more far away from being next gen in this current state. This goes for vehicles, interior lighting, view distance, weather systems, ragdoll even map creating ...

it will still take years not months to get everything on par with the current used next gen engines used in other games....and DayZ being the proving ground

 

 

Share this post


Link to post
Share on other sites

I often notice one strange pattern when the server is lagging behind.
If I accelerate the movement forward, the character throws, or you can see the character jumps. But in other situations, acceleration does not reproduce jumps.
I think everyone had a bad experience when climbing the vertical stairs, on the roof of a building or on a tower ... When I accelerate to the top of the stairs, I can get a strong lag. If you continue to accelerate to the top, you can lose touch with the stairs, fall \ fly off the stairs and die. But if you speed down the stairs, the speed of rapid descent does not reproduce the lag for the character. In both actions there is a rapid movement of the character, but the lag is recorded only in one direction of movement. It seems that the lag occurs only when the server calculates the expenditure of energy of the character in motion, and not the fact of a rapid change in the position of the character. Movement of the character to the top of the stairs causes a large expenditure of energy and down without spending energy.

Share this post


Link to post
Share on other sites

Cars work pretty good in offline mode... It just becomes a bit sad to get a new car in the last patch while online they are almost unusable due to server performance issues.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×