mr.con2@hotmail.com

BattlEye Failed to Update (Again): Kicked from Game.

38 posts in this topic

I've read numerous (and by numerous, I mean a LOT of) threads dedicated to solving this infamous updating issue with BattlEye. After reading every post on every single one of those threads, and trying every bloody suggestion they threw at me, I've managed to get the "BattlEye Faield to Update: You have been Kicked from Game" again, and again, and AGAIN.

I've downloaded the latest BattlEye client and server .dll's and placed them in my BattlEye folders (both ArmA II and ArmA II: OA, and just OA, and then just ArmA II, and then neither, and then both again, etc. etc.). After placing these v1.62 (or whatever the latest version is) files into the folder, I am then greeted by "BattlEye requires client version 1.168" or some other bla-bla and am told that BattlEye is trying to update. Every once in a while I get right to the point where the words Chernarus and Day 1 and all that are being typed onto my screen when the message "Failed to Update" comes on, though it usually facepalms me before that, which, as a consolation, is less enraging than spawning as your character (meaning "OH YAY! Play time! =D") and THEN being kicked. This by the way is all after having downloaded the latest version (which has been repeated many times as the way to "fix" my problem).

I've set all my applications (ArmA II, ArmA II: OA, ArmA II: PMC, etc., etc., DayZ Commander) to run as Administrator by checking the box in the compatibility window. This administrator tactic was another alleged fix to my situation. It failed, of course. =P

I've tried messing with my router, reinstalling stuff, joining different servers, trying to find maps through the in-game servers rather than through DayZ Commander itself, using Six Updater (or Play withSIX or whatever it's called now), and all to no avail.

I have absolutely NO idea what the flugelhorn is wrong with this "anti-cheat" BASTARD. I would absolutely LOVE to play this fantastic mod of a fantastic game, but am currently unable to because of the tiniest, most insignificant (in my opinion) part of the whole process. BattlEye.

And after all that struggle to just get the damned DayZ mod to work in the first place. Finally ready and I get this BattlEye fluff (which I previously had not even known to exist).

Please, please, please, and Please HELP. I run a Windows Vista and have a cat shouting "YOU GOT ME RIBBONS!! OMG! OMG!!" as my background.

If anyone would be kind enough to figure out what the flugelhorn (pass that saying around, by the way) is wrong with this, please comment.

Also, that whole ShareMyPC or whatever (where you control another person's computer as if it were your own over the internet) might be EXTREMELY helpful. I've had problems solved quite easily using that before. =P

Anyways, please help. I would appreciate it, as well as anyone else who is having my problem. Thanks. =)

Share this post


Link to post
Share on other sites

If you've ever spent 2 hours trying to open a guitar case and then angrily ranted to the company about giving you a broken lock, and then realized that it wasn't locked at all and and you only needed to push the handles SIDEWAYS to open it, then you might understand my current emotion.

You see, I've been having this ridiculous BattlEye problem for quite a while, and have FINALLY solved it. And to make it hilariously facepalmish, it was because I was impatient.

As it turns out, my BattlEye would update, just slowly. So when I decided not to click "OK" in the lobby (where it shows the survivors) and instead wait, facing my inevitable doom, I was surprised to eventually see "BattlEye client initialized 1.168: Up-to-Date." WTF? Haha.

Never once had anyone seemed to suggest that the problem might simply be that I was failing to download it before entering the game. Laugh out loud.

SO ANYWAYS--- try just not clicking OK once you enter that lobby. With any luck, you'll find out that the whole damn problem was just that it didn't update fast enough for you to go zombie hunting.

Cheers, and good luck. =)

Edited by CrazyCon

Share this post


Link to post
Share on other sites
try just not clicking OK once you enter that lobby. With any luck, you'll find out that the whole damn problem was just that it didn't update fast enough

Battleye updates during gameplay, so clicking OK shouldn't hinder it doing so. When I first got kicked it was at least half an hour after clicking OK to get into the game. It sounds like your Battleye managed to update, and you've contributed it working to the fact that you were in the lobby, which might be totally incidental. I'll give it a go all the same, but I wouldn't call it a fix until enough people have had it consistently work.

#Edit :

After waiting a minute in the lobby, Battleye did update and work. I was only kicked twice in a row before, so can't say it wouldn't have updated anyway.

Edited by Hudson633

Share this post


Link to post
Share on other sites

If you use PeerBlock or something similar, make sure that you turn it off. It will prevent BattleEye from being able to update.

Edited by TemperMode
gadlaw likes this

Share this post


Link to post
Share on other sites

i'm having the same problem,i have only played dayz for few days and now i get on 1 sever then get kicked off cos it says battleye failed to update :(

Share this post


Link to post
Share on other sites

Well guys i reinstaled both my arma2 and op instaled battleye again, soo where did that lead me? Im currently trying to enter any server at 2 fucking hours!! WTF Ive been kicked from 100+ servers.Legit players cant play but hackers can? Fucking kidding me!?

darkangel___ likes this

Share this post


Link to post
Share on other sites

Worked for me...

Was having the "failed to update" issue as well. I would make it inside the game for about 10-15 seconds before I got booted by battleye. It would not update while in game. Saw this thread, joined a lobby and simply waited for it to update and it did update not long after. Thanks.

If you've ever spent 2 hours trying to open a guitar case and then angrily ranted to the company about giving you a broken lock, and then realized that it wasn't locked at all and and you only needed to push the handles SIDEWAYS to open it, then you might understand my current emotion.

You see, I've been having this ridiculous BattlEye problem for quite a while, and have FINALLY solved it. And to make it hilariously facepalmish, it was because I was impatient.

As it turns out, my BattlEye would update, just slowly. So when I decided not to click "OK" in the lobby (where it shows the survivors) and instead wait, facing my inevitable doom, I was surprised to eventually see "BattlEye client initialized 1.168: Up-to-Date." WTF? Haha.

Never once had anyone seemed to suggest that the problem might simply be that I was failing to download it before entering the game. Laugh out loud.

SO ANYWAYS--- try just not clicking OK once you enter that lobby. With any luck, you'll find out that the whole damn problem was just that it didn't update fast enough for you to go zombie hunting.

Cheers, and good luck. =)

Share this post


Link to post
Share on other sites

Worked for me too. It took about 5 minutes to update.

Worked for me...

Was having the "failed to update" issue as well. I would make it inside the game for about 10-15 seconds before I got booted by battleye. It would not update while in game. Saw this thread, joined a lobby and simply waited for it to update and it did update not long after. Thanks.

Share this post


Link to post
Share on other sites

the same happens to me BUT i can't even get into the lobby so i can't wait for battleye to update FML. >:( :( <_<

Share this post


Link to post
Share on other sites

>_> this failed to update has pissed me off too much, I try everything, still "Kicked From Server: Battleye Failed to update"

can we use something other than battleye? because its making people get kicked way too much.

darkangel___ likes this

Share this post


Link to post
Share on other sites

Logged out of a server where a hacker teleported everyone to a field north of Cherno.

I have to say the fact I can't rejoin a server being attributed to the anti-cheat that allowed a player to teleport an entire server . . . feels bad.

Share this post


Link to post
Share on other sites

Waiting in lobby for update (maybe 3-4 minutes) worked for me, after getting kicked twice in a row.

Share this post


Link to post
Share on other sites

battleye sucks hackers bullets. worst ANTI-CHEAT ever...(anti-cheat LOL)

got same problem "failed to up-date" luckily happened just before entering town, so im not stuck in middle of road with 20 z's around me, then i would be p1s*%& off

5 times lobby didnt work either

Edited by dkangel

Share this post


Link to post
Share on other sites

This might sound stupid. But I tried everything else and got nothing.

First of all, there is a thread here somewhere, called "BattlEye Fix Steam" or something, which will tell you to put the latest version of BattlEye into three different directories, that gave me a few promising results, so maybe try that.

Then - turn off windows Firewall.

I got a new message before getting stuck at the Green Loading Screen - "BattlEye updating", it did, it initialized, and I wasn't kicked while waiting in the lobby or anything! So looking good!

Share this post


Link to post
Share on other sites

Failed to update: For some reason your BattlEye Client is not able to download new updates from the BE Master Server - most likely related to your internet connection. Please download the most recent version for your game from the download page and manually update your BE Client.

http://www.battleye.com/support.html

http://www.battleye.com/download.html

Share this post


Link to post
Share on other sites

same shit here ...... after being in game for 30 min got client not responding and since then can not get on to server.... fix it now ........ I'm having this issue for 5 days now ....

Share this post


Link to post
Share on other sites

Failed to update: For some reason your BattlEye Client is not able to download new updates from the BE Master Server - most likely related to your internet connection. Please download the most recent version for your game from the download page and manually update your BE Client.

http://www.battleye.com/support.html

http://www.battleye.com/download.html

I've done this procedure... we need the game producers to solve this problem.........

Share this post


Link to post
Share on other sites

Its interesting....

If its not your Internet connection, and its not the BE Master server that is overloaded, and you have tha latest dll´s....and there is thousands of players with no problem....what could it be?

How is your HDD? Checked for faults? When did you do a defrag last?

Edited by Drogur

Share this post


Link to post
Share on other sites

Its interesting....

If its not your Internet connection, and its not the BE Master server that is overloaded, and you have tha latest dll´s....and there is thousands of players with no problem....what could it be?

How is your HDD? Checked for faults? When did you do a defrag last?

It's not just him ..... plenty of people having this issue ... didn't you notice how many players got Battleye not responding message while you have been playing? I saw a plenty of them.

Share this post


Link to post
Share on other sites

It's not just him ..... plenty of people having this issue ... didn't you notice how many players got Battleye not responding message while you have been playing? I saw a plenty of them.

It comes and goes as I seen it....still, the majority doesnt have this problem.

Still a problem though.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Similar Content

    • By Halen
      I have been having issues connecting to public servers for the last 2 weeks or so.  When I try to connect I get to the 'ready!' state and when the game is just about to connect I get the message: "Connection to the server has been lost".  When I try to connect again I get the 95 second wait timer and when it is just about to connect to the server I get the same message.
      I am able to connect to private servers so this issue baffles me a bit. I have verified my game cache files and have even uninstalled and reinstalled the game once.
      Any help would be appreciated.
      Thanks,
      Halen
    • By EpiGamer
      Today we have launched a new Day Z Origins server called United Gaming. This server is hosted in Paris and therefore will offer low ping for EU players. Players from all countries are welcome to join. As a new server we are looking to build our player base so that we can form an active community.

      This server is 70 slots, and therefore is one of the only Day Z Origins servers with this high player capacity!
      The benefit of this server is that the majority of the Day Z mod player base will have a lower ping since it is hosted within Europe.

      I am looking for a staffing team willing to help manage and maintain the community, if you have experience in this area and are familiar with Arma 2 Day Z mod then please feel free to message me.

      We have a Discord setup for voice and text communications, we are using this service over TS3 because it offers more functionality and overall is a better service. Join the server now whilst it is low population and have a head start on building your base!
      DAY Z ORIGINS SERVER
      To connect to our Day Z Mod Origins server please use the following IP address;
      37.187.143.216:4623
      DISCORD
      To invite other players to this Discord, please send them this link to join.
      https://discord.me/unitedgaming
      If you are having problems installing or setting up Day Z origins, before asking for support please follow the steps below.

      HOW TO SETUP/JOIN
      1) Ensure you have both ARMA 2 and ARMA 2 OA installed/verified.
      2) Ensure you have run both ARMA 2 and ARMA 2 OA at-least ONCE
      3) Download and install the latest version of Day Z Launcher from Google.
      4) Install ALL versions of Origins mod through DayZ Launcher, ensure 1.8.2 is installed.
      5) Using the IP/Port posted above, paste this into the "Name" field and hit Enter on your keyboard.
      6) Favorite United Gaming when it appears in the list and double click on it to launch the server. Click OK on the Steam popup message.

      Information on Origins Mod see - https://wiki.originsmod.info/index.php?title=Main_Page