semipr0

Two computers, different IP's, same house, cannot connect to same server

71 posts in this topic

Few days ago I got Arma 2 for my wife so she could play DayZ with me. We played for a whole day with no problems whatsoever. The next day I died in an accidental friendly fire situation, after I died and tried to login to the server, my wife's client suddenly stopped communicating with the server and lost connection, and I was unable to make a full data connection.

Now no matter what we do, if I'm on US 155, and she tries to join, my client stops communicating with the server and I eventually time out, and she cannot log on to the server at all til she retries after I'm off. If I try to log in behind her, she gets dropped from the server in the process. And this happens on any server we try to join together.

We have two seperate IP's, we have seperate CD keys for our Steam installations of Arma 2 CO, and we can both play just fine as long as we're not on the same server.

I've reset our router, updated its firmware, flushed both our DNS caches and the problem continues to persist.

Anyone else seen anything like this and know any solutions?

Share this post


Link to post
Share on other sites

I want a wife to play DayZ with man. That's wicked. I'm so pissed that you can't play together right now, that's lame. Sorry I can't help, just wanted to help fuel your rage about this. Best of luck pal.

Share this post


Link to post
Share on other sites

Not really raging, just trying to work it out. Had some friends on our Teamspeak end up with the same problem tonight too so they didn't play tonight so our little band of survivors was short 3 people. I eventually logged out cause of a lack of ability to play with my wife and friends.

Share this post


Link to post
Share on other sites

Have you swapped computers by chance? - I imply that both your player profiles may be on both computers raising a conflict of some sort?

Share this post


Link to post
Share on other sites

perhaps use an IP changer? Don't know much about networking and stuff though..

Share this post


Link to post
Share on other sites

Have you swapped computers by chance? - I imply that both your player profiles may be on both computers raising a conflict of some sort?

We never log into each others Steam accounts. Neither computer has a profile for the other account. I've checked that too.

Share this post


Link to post
Share on other sites

If I understand, your PC's have different IPs, but they are connected via one router - modem, which has only one IP. That would be the problem.

Edited by Clasius

Share this post


Link to post
Share on other sites

perhaps the other computer can use someone elses wi-fi?

Share this post


Link to post
Share on other sites

If I understand, your PC's have different IPs, but they are connected via one router - modem, which has only one IP. That would be the problem.

Even then we had no problem connecting to the same server the first day she played with me. It only started happening the next day after I died, now we cannot play on the same server together.

If what you are proposing was the case we'd have had the problem from day one, not on day two.

Share this post


Link to post
Share on other sites

If I understand, your PC's have different IPs, but they are connected via one router - modem, which has only one IP. That would be the problem.

Correct. Both of your computers will have a seperate private IP address. This private address identifies you on the network and usually starts out as 192.168.0.XX.

Your IP address on the internet is what is know as a public IP address. Your public IP address is assigned by your ISP to your router, which is what the rest of the internet sees. To test simply google "whats my ip address".

:)

A solution would be to connect to a VPN from one computer (which will route all your internet traffic and give you a new public IP address) and run the others internet traffic through the router as per normal.

Share this post


Link to post
Share on other sites

Even then we had no problem connecting to the same server the first day she played with me. It only started happening the next day after I died, now we cannot play on the same server together.

But it's strange to attribute the problem that you died, and after that you can't connect.

I would try this:

A solution would be to connect to a VPN from one computer (which will route all your internet traffic and give you a new public IP address) and run the others internet traffic through the router as per normal.

Share this post


Link to post
Share on other sites

Looks like dayZ has no support for identical IP addresses. My only suggestions are to:

A. Connect through a different internet connection(not ideal really)

B. Use a proxy server to connect one computer through before joining the game.

C. Some sort of ip changer which i am not very familiar with.

Niall

Share this post


Link to post
Share on other sites

Looks like dayZ has no support for identical IP addresses. My only suggestions are to:

A. Connect through a different internet connection(not ideal really)

B. Use a proxy server to connect one computer through before joining the game.

C. Some sort of ip changer which i am not very familiar with.

Niall

A proxy sever will only reroute traffic on port 80 (HTTP) by default (ie a web proxy) - there are specific proxies for different ports by 99% are for HTTP traffic.

A VPN will cover off point A & C. Instead of rerouting just web traffic (port 80), the VPN will reroute ALL traffic from your computer to its interface.

Have a look at the following article from Microsoft for connecting to a VPN (This guide is for Windows XP however connecting to a VPN from Windows 7 nearly identical):

http://support.microsoft.com/kb/314076

Share this post


Link to post
Share on other sites

Looks like dayZ has no support for identical IP addresses. My only suggestions are to:

A. Connect through a different internet connection(not ideal really)

B. Use a proxy server to connect one computer through before joining the game.

C. Some sort of ip changer which i am not very familiar with.

Niall

My brother and I connect through the same router without any problem whatsoever, it's probably one of the internal router / firewall / ?peerblocker? settings.

Share this post


Link to post
Share on other sites

I've been pouring through my router settings and there isn't anything different there that wasn't there as of a few days ago.

Share this post


Link to post
Share on other sites

Our IPv4 addresses are different but our external IP Is the same.

I've forwarded all the relevant Arma II ports in my router. We still cannot connect to the same server, for some reason the servers cannot filter our NAT addressing and realize that we're two different computers attempting to connect to the same server.

Share this post


Link to post
Share on other sites

The server will never realise that you are two different computers connecting. This is because your internal network is private and unable to be seen by the DayZ server. There is no issue with your router - you are able to get to the server correct? Regardless of if one of you is not able to play or not. That means that the server on the other end is rejecting the connection.

Share this post


Link to post
Share on other sites

We've been gaming with the same internet connection and home networking set up for years now, we've never had any problems playing together on the same servers for any game other than Arma II/DayZ.

Share this post


Link to post
Share on other sites

My roommate and I are having the same issue, started happening after we upgraded from patch 94876, but downgrading both the patch and battleeye has yet to fix it. Still trying to find a solution, we've never had any issue of the sort before and have been playing DayZ on the same setup for about a week prior to this cropping up.

Share this post


Link to post
Share on other sites

My roommate and I are having the same issue, started happening after we upgraded from patch 94876, but downgrading both the patch and battleeye has yet to fix it. Still trying to find a solution, we've never had any issue of the sort before and have been playing DayZ on the same setup for about a week prior to this cropping up.

Well as I said my wife and I were able to play for a day with no issues whatsoever. This was after the 1.7.2.3/94876 update last Friday. She has updated via Six Launcher several times and run into problems getting onto servers running 94876 still so I've gone in and manually removed the latest update and reinstalled the 94876 beta on her computer...but even that and manually reinstalling BattlEye hasn't allowed us to play on the same sever together since Monday 07/16.

And its not just one server that rejects us both connecting, any server we both try to get on together.

If I am already on a server and my wife tries to join it, I get a yellow latency link, then a broken red link and the message that I've stopped communicating with server over and over, once she actually gets to the game lobby, my player name isn't even in the lobby list any more, and when she tries to load in to the game environment, she can't download the full mission file, and has to exit out of the game.

This is definitely very weird because its not like every computer connected to broadband internet has its own individual IP, home networking is extremely common and theres absolutely no reason why we should need two dedicated internet connections or have to pay for a VPN for one computer simply to play this game.

Something about the DayZ server package is denying multiple connections from the same network address and its just started coming up recently.

Share this post


Link to post
Share on other sites

Yea, I created this thread right before seeing yours: http://dayzmod.com/forum/index.php?/topic/37535-wait-for-host-error/

We're in the same exact boat, whoever connects first can play, the second person just gets stuck on "Wait for host", even after leaving, it takes about 5mins before the second person can join the server.

I just tried connecting to the same server as my roommate through my phone, and it worked fine albeit my ping was quite.. spectacular.

I'm going to see about setting up a VPN until this gets resolved, I'll PM you details for it if the lag is not too bad

Share this post


Link to post
Share on other sites

I've created a bug report here https://dev-heaven.net/issues/37534, if anyone else experiencing the issue wants to weigh in on it, it might help get the problem some attention.

I've also sent a support request to BIS and put up a thread on their trouble shooting forum.

Hopefully an answer to the problem becomes apparent soon.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

  • Similar Content

    • By nl
      0.59 Stable. Another bug (imo) that I hope is resolved soon. I mean I can imagine with a lot of gear I would sprain or break an ankle falling from a 40 centimeter height, but dead...Ah well, I was ready to say goodbye to this character anyway in anticipation of 0.60.
       
    • By RUSSIAN WARRIOR
      Why i have this problem.I have arma 3,Arma 2 CO,DayZ.Are this games compatible???I dont know,but i know that i always have problems with launch this games.Help me plz again.
    • By PeePeeMcStuffnpants
      PeePeeMcStuffnpants and Abraxxas are at it again.  The Dynamic Duo of Mayhem's 50th Video Brings Some Serious Action.  We Set Off On Bikes to Buy A New SUV.  What We Get For Free is Way Better!  Stayed Tuned, After the First Adventure, For Some Bonus Footage! (With Our New Amigo, Burton(MasterBlaster)
       
      [media]https://www.youtube.com/watch?v=v6zbDd6uRaY[/media]