Jump to content
Sign in to follow this  

Battle eye failed to read initalization file. was working fine before. Fixed! Link Below!

Recommended Posts

As title says it was working perfectly fine I guess till today. it would give me a white popup everytime I click on a server play button saying initializing BE.... failed to update BE.. and a whole paragraph below that. but it would popup an disappear so fast like 1 sec I cant read the rest then mod server would go ahead an launch, I'm using day z launcher. 

its so confusing why cant it just be simple an work? ive tried disabling antivirus uninstalling BE but its even hard to get it to uninstall. seems like I have BE everywhere. if I uninstall it in programs its still in my arma 2/OA/folders I have all this in my second drive. but then in my main c drive I still have BE files as well. program files 86x/common files/BE....BEService.exe, BEService_arma2oa.exe, BEService arma3.exe.

on sec drive steamapps/common/arma2/ first folder is 'battle eye" which has files BEClient.dll, BEServer.dll, UninstallBE.csv, UninstallBE.exe, UNinstallBE.log. Sec folder has files checkFileList.Ist, setup_BattlEyeArma2.exe

Arma 2 Operation arrowhead/ battle eye folder with BEClient.dll, BEServer.dll. then in expansion folder where all my mods are installed there is a battle eye folder with files, BEClient.dll, BELauncher.ini, BEServer.dll, beserver.so, BEService.exe, BEService_x64.exe, Eula.txt, Install_BattlEye.bat, Uninstall_BattlEye.bat.

if I click on those a black cmd? screen pops up for split sec an disappears an does nothing after that.

what do I need to do delete/install all BE folders/files manually? why all of a sudden does it not work an before I could launch play mods just fine?

much appreciate any help.

PS, sent a ticket to BE.

Update: deleted all battle eye files an folders verified game cache through steam it got everything except OA of course. OA still doesn't work this time I noticed it didn't install BEServer.dll only BEClient.dll in users/name/appdata/local/Arma2 OA on my main c drive. so I copied BEServer.dll to there. 

If I click on file ArmA2OA_BE.exe it says same thing so somethings missing somewhere? OA the game itself in steam will not launch with battle eye.


Many thanks to TheGamingchief! here is the link to his youtube video with the fix. https://www.youtube.com/channel/UCNcEunpAipvdCsBNffRc36A for me it made a BE installation popup an I simply went through setup took 3 secs or so. he just published the video yest. or few hrs ago.

or if link does not work "TheGamingChief" on youtube. title says "How to fix ArmA 2 BattlEye failed to read initialization file [2018]" <spelled exact like that. just hate BE dictating whether I can play or not,  those ppl cant make anything work right an break what does work an most gamers are smarter an fix their broken trash.  he said BE just broke "again" so I'm not only one who had this issue. wonder if BE ever heard of this> KISS <"keep it simple stupid"

Edited by Aqualyt
wrong spelling in title

Share this post

Link to post
Share on other sites
15 minutes ago, BCO Games said:

What worked for me is simply restarting the pc and launching the game again.


wow lucky you.

Share this post

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
Sign in to follow this