Jump to content
Sign in to follow this  
joe_mcentire

watch out when using Intel Compiler Patcher (ICP) - Battleye doesn't approve it

Recommended Posts

just a short fyi. As an AMD user I was rather curious when i heard about ICP at first and went on to use it on my computer not fully aware of all the implications it would come with. You can basically define a folder-structure where this tool will search for intel compiled code and then offer a fix (and backup) to remove the "code obstacles" which intel deliberately integrated to impede non-intel cpus.

 

Well, in principle, I had no issues until i fired DayZ up again:

 

0029526: game does not start: "blocked loading of file C:\Windows\SysWOW64\aticfx32.dll" (Intel Compiler Patcher interfers with game)

 

UlmhWOP.png

 

The interesting thing is, it had no trouble with altered files in my steam folder, however, what happens here is that Battleye seems to scan dll files within your windows directories as well resulting in errors as the one above.

For example, my SysWOW64 folder had about 18-22 altered files from which I had roughly 8-11 to revert to their original state.

 

The game simply won't start at all. So just in case to you AMD users out there, if you use ICP, use it wisely. Me, I have no idea why i really used it in the first place.

 

So just a quick heads-up

 

Edit:

I also mailed BE questioning what it would mean for me as a user and if that issue could potentially produce false-positives on their side; still waiting for an answer here.

Edited by joe_mcentire

Share this post


Link to post
Share on other sites

hi

aticfx32.dll should be in part of your ATI video card driver (as far as I can see) - you got an ATI on your AMD ?

if so - reinstall the driver. to get back to the original

 

ICP should make backups of the exec before it shortcuts an Intel C++ code element (CPU Dispatcher) the "Dispatcher" is included in exec files compiled on an Intel C++ Compiler

 

or probably (usually)  MS Visual C++ ..  [groan]  etc etc.. 

It is an Intel thing, but lots of folk using MS visual C++ don't bother to switch on the "make compatible with AMD"  box, due to brainwashing (right lads?)..  a wonderful and historical ever-changing situation

 

Some software does not like being interfered with, counts it as reverse engineering (or hacking, I guess) and will complain.

But you cannot be the only person to have run into this problem. Battleye should be aware of it.

 

At the worst - just reinstall the whole game? As it runs already on your AMD, using ICP on it wont make any big difference there IMO.

 

xx pilgrim

 

[edit: all those years AMD was in front they gave us s**** and now they pretend we don't exist.. heh ...no change]

 

[edit edit] jeez - it's like training a dog, you have to decide who is boss - computers can really ruin your day if you let them, right ?

Edited by pilgrim

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

  • Similar Content

    • By Melis
      The rx460 graphics card, the driver 18.5.2. On weekends there was a stress test of 0.63 games dayz standalone when turning antialiasing on start rippling the textures of trees and grass (covered with light points). Similar it was before( in 0.60,0.61,0.62), but only with trees, now everything is worse. It is only the complete disabling of antialiasing that helps. On Nvidia cards is not a problem. I understand that the game is under development, but can solve the problem? 
    • By S3V3N
      Hi, for the first time in years I'm thinking about getting an AMD card again. I found the RX480 does everything I need and wonder if anyone is using the card with Dayz. For one reason it's not as power-hungry as the NVidia ones I can get for the price. Secondly, I don't want to buy a used card and this is in a good price/value relation. If any other cards come to mind that would be a good buy in the upcoming months, please let me know below.
    • By Stary_Prase
      Dear all,
      I play on an Asus ROG G750JM, and it has two video cards, an integrated Intel HD Graphics 4600 and a NVIDIA GeForce GTX 870M. Connected in HDMI there is a secondary monitor, a BENQ which works well (can stand 1080p with any other game).
      Intel Driver version is 10.18.15.4256,
      Geforce one is the latest one.
      the issue is, when running Dayz 0.60 exp, if I run it on my laptop screen, all is fine (normal 1080p). If I run it on my bigger screen, (I bought that for dayz mostly anyway), the screen turns into 1080i, flickering and aching my eyes. The monitor itself can sustain 1080p very well, but with only dayz this happens. Can you help/fix?
×