• Announcements

joycey07

Bad version, Server rejected connection

15 posts in this topic

I am trying to join my clans server, and every time i do, i get 'Bad version, server rejected connection'

I have updated EVERYTHING i possibly can.

I've un-installed all my Arma 2 add ons and Arma 2 it's self.

I've re-installed everything that is required

I've re-updated all required add ons

I've been able to access this server before and have played it for a long while. but this is a new problem for me.

I have had no problems prior to this.

I have tried through DayZ Commander, Six Launcher and Arma 2's standard multiplayer server searcher.

Anyone have any ideas on how i can gain access to my clans server?

Share this post


Link to post
Share on other sites

UPDATE: I can't access ANY Day Z servers

Share this post


Link to post
Share on other sites

Have you tried downloading the latest beta? Sometimes DayZ commander doesn't display the latest patch.

http://www.arma2.com/beta-patch.php

It's pretty simple if you havent done it before, DayZ commander will, once you've installed the beta, automatically start using it. All you really need to do is keep clicking buttons.

Edited by TheDesigner
ruskieconrad and joycey07 like this

Share this post


Link to post
Share on other sites

As TheDesigner said, you need to go and download the latest beta patch. 'Bad Version' means that the version of the patch you are using for the game is outdated. Alternatively, you can go and open your Arma II OA folder and scroll down until you see the shortcut called "Launch Arma2 OA Beta Patch". You just double click that, and the game runs automatically and updates the patch for you. This fixed my errors with the beta patch updating; it's pretty quick.

Majo (DayZ) and joycey07 like this

Share this post


Link to post
Share on other sites

I created an account just for this question. I have the same problem. Where is this Arma 2 OA folder you guys are talking about. IT is not in the steam folder..

Share this post


Link to post
Share on other sites

Same problem here..

Figured it out, when you download it, open it with winwar. Then double click the program, and keep clicking/following the install wizard. It should install, and then your good. Thats all I had to do.

Share this post


Link to post
Share on other sites

I just downloaded the latest patch and it is still prompting me with the same error

Share this post


Link to post
Share on other sites

I checked the problem !

when i install all the latest updates, i even can´t joint lots of servers !

and why, coz the version i am using is still an old one, how to see the real version, in the main menu of arma 2 all down right ya see what version ya using !

but how changing the version, if its not posible with the dayz commander, or manualy install ! ?

Share this post


Link to post
Share on other sites

Lots of servers can't/don't update immediately so when it's up for you as a player it might not have been run on the server yet.

I've found Play with Six is the most reliable of the installers for the mods and it has TONS to choose from too...

Sometimes the server settings can be messed up too so it's kicking people it shouldn't.

Share this post


Link to post
Share on other sites

I download and run the installer for 99515 (or whatever dayZ commander says the servers are running) from the update site, and install it, but when I run it I get the same error and I check the version in the game and it says its a diferent one.

Share this post


Link to post
Share on other sites

Try going into the Arma II OA folder then Expansions > Beta, copy the arma2oa file to the arma 2 OA folder, you can move the current file in there, else where, and just use this as the launcher, seemed to resolve the problem for me.

Share this post


Link to post
Share on other sites

I have a fix for this, I had this exact problem, download this CMD file, place it inside the ArmA 2 OA directory, and make a short-cut and place it on the desktop, you then run that CMD to open up dayz/arma and you should run dayz with the correct version if they have been installed. I Have made the script, it has trouble shooting so will work with most directories :) Hope this helped! I know I am very late but I hope this may help others!

Download: http://www.mediafire.com/download/d04f9e87wn959n1/DayZbeta.cmd

Share this post


Link to post
Share on other sites

I have a fix for this, I had this exact problem, download this CMD file, place it inside the ArmA 2 OA directory, and make a short-cut and place it on the desktop, you then run that CMD to open up dayz/arma and you should run dayz with the correct version if they have been installed. I Have made the script, it has trouble shooting so will work with most directories :) Hope this helped! I know I am very late but I hope this may help others!

Download: http://www.mediafire...n1/DayZbeta.cmd

You dident write that, you edited the run line by adding @dayz; :P

Edited by Fully

Share this post


Link to post
Share on other sites

INSTALL THE ARMA 2:OA BETA [From Steam]

 

-Open DayZ Commander

-Settings

-Tick: Launch using Steam, Replace original ARMA 2:OA files with Beta so Steam works.

 

NOW TRY IT?!!

 

It worked for me perfectly:))

post-173399-0-10066700-1385942906_thumb.

Steak and Potatoes likes this

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

  • Similar Content

    • Server Performances Private Hive, or Public -Desync issues
      By sneakydude
      I need your guys assistance to explain exactly what is going on with your errors, or warping backwards when the server becomes unstable.
      Objects do not pickup, doors may or may not open. PVP shooting a player and they will not die, Infected are invisible, or simply hitting you and you are being killed without doing any damage to them.
      I have started a bug support for it, and in hopes most of the same issues get merged into these reports.
      https://feedback.bistudio.com/T119619
      This is usually seen to me as a memory reference error can not be written to. I have 2 fresh installs and the same error. It is destabilizing the server and the clients. Sometimes you may error out of the game, or desync with others in the area.
      The server goes crazy, and warps you back into an old area.
      If you have any more constructive information for the devs please visit that link and support this fix asap.
      It is making the game unplayable since the newest hotfix has been released.
      Please visit

      Those videos, are exactly what is going on. Some are experiencing it more then others i would gather.
      Thanks
      Sneakydude
    • I NEED HELP MY GAME WONT LAUNCH
      By KND
      am trying to launch my game from steam but it wont work.
      First it tells me battle eye is launching and stuff then this pops up.

      I have tried running my game as a administrator and tried verifying game cache 
    • What Should I Upgrade to Get Rid of Stuttering/Lag and Add Graphics
      By gosephness
      I currently have:
      AMD FX 6300 (Overclocked to 4.1ghz)
      Crucial Ballistix 1600mhz (8gb installed but it says 4gb hardware reserved)
      Sapphire Radeon R9 270x 4gb oc Dual-x
      Western Digital blue 1tb
      I have heard that an SSD could fix my problem. Is this true?