CallMeRive

OBS (Open Broadcaster Software) "Game capture" function does't work with 0.60

31 posts in this topic

OBS Classic (Open Broadcaster Software) "Game capture" function doesn't work with 0.60.

Drivers, updates and other info is irrelevant – if one reverts back to 0.59, everything works again.

A lot of evidences from different streamers across Twitch, Twitter etc. For example, from here: 

 

Please, fix it, because Game capture method is recommended for streaming and it was the more convenient way to stream DayZ.

P.S. I know about windowed mode (window capture) and monitor capture. Game capture is still better.

UPDATE: There is a workaround for this problem: disable Anti-aliasing in the game to get game capture feature working again. Big thanks and respect to Le_yakitoid, who told us about it. :)

Edited by CallMeRive
tags update
barelyinfected and beorne like this

Share this post


Link to post
Share on other sites
39 minutes ago, Le_yakitoid said:

For now try disabling anti-aliasing. OBS works for me if  AA is disabled.

Using gamecapture?

Share this post


Link to post
Share on other sites
24 minutes ago, barelyinfected said:

Using gamecapture?

Yes, using game capture. Also try setting the game capture to hook to the game using a hotkey. If nothing works, then the problem on your end is something else, just mess around with your configs.

Share this post


Link to post
Share on other sites
1 hour ago, Le_yakitoid said:

Yes, using game capture. Also try setting the game capture to hook to the game using a hotkey. If nothing works, then the problem on your end is something else, just mess around with your configs.

Really strange, I will look into that later today. As far as I know, most streamers and youtubers I know use monitor capture instead of game capture at the moment with 0.60. I'll report back. Thanks for the tips.

Edited by barelyinfected
CallMeRive likes this

Share this post


Link to post
Share on other sites
2 hours ago, Le_yakitoid said:

For now try disabling anti-aliasing. OBS works for me if  AA is disabled.

Thank you for the tip, but I want to use antialiasing and it actually worked in previous patches.

1 hour ago, Le_yakitoid said:

Yes, using game capture. Also try setting the game capture to hook to the game using a hotkey. If nothing works, then the problem on your end is something else, just mess around with your configs.

Well, you're... well, not quite right here, 'cause if we take DayZ 0.59 in out-of-box state, OBS game capture works, but if we take 0.60 in the same state – alas! So no need to mess around cfgs, it's just a DayZ problem, not user's.

Share this post


Link to post
Share on other sites
2 minutes ago, CallMeRive said:

Thank you for the tip, but I want to use antialiasing and it actually worked in previous patches.

Well, you're... well, not quite right here, 'cause if we take DayZ 0.59 in out-of-box state, OBS game capture works, but if we take 0.60 in the same state – alas! So no need to mess around cfgs, it's just a DayZ problem, not user's.

Yes, that is true, but if it's a workaround to get me to record with OBS atm, I'll be happy and we can narrow the problem down right?

Share this post


Link to post
Share on other sites
1 minute ago, CallMeRive said:

Well, you're... well, not quite right here, 'cause if we take DayZ 0.59 in out-of-box state, OBS game capture works, but if we take 0.60 in the same state – alas! So no need to mess around cfgs, it's just a DayZ problem, not user's.

I meant Dayz Configs, sorry for misleading. But yeah, its probably a problem with AA in the new renderer. It will get fixed soon enough.

 

Also, quick note that I forgot to mention, I'm playing DayZ in windowed mode.

Share this post


Link to post
Share on other sites
8 minutes ago, Le_yakitoid said:

Also, quick note that I forgot to mention, I'm playing DayZ in windowed mode.

So it doesn't work in fullscreen?

Share this post


Link to post
Share on other sites
1 minute ago, barelyinfected said:

So it doesn't work in fullscreen?

Just tested. Working fine in full screen mode. [ AA still disabled. ]

barelyinfected likes this

Share this post


Link to post
Share on other sites
Just now, Le_yakitoid said:

Just tested. Working fine in full screen mode. [ AA still disabled. ]

Cool cool, thanks, I'll test it out and I'll report back. :)

Share this post


Link to post
Share on other sites
1 hour ago, Le_yakitoid said:

Just tested. Working fine in full screen mode. [ AA still disabled. ]

I just want to say that you helped a lot of people here: 

 

Le_yakitoid likes this

Share this post


Link to post
Share on other sites
5 minutes ago, barelyinfected said:

I just want to say that you helped a lot of people here: 

 

Cool, now we can all enjoy the awesomeness of fresh .60 DayZ content :D

barelyinfected likes this

Share this post


Link to post
Share on other sites

I've updated first post with this workaround. Thanks to Le_yakitoid, he really helped a lot of people (and good streamers, btw! :).

Share this post


Link to post
Share on other sites

Note, I am speaking specifically of game capture, not monitor capture.

This still doesn't work in OBS Classic.  Dayz 60 will not work at all in OBS classic, at least not for me

This only works in OBS Studio and ONLY after disabling AA.

Share this post


Link to post
Share on other sites
3 hours ago, thebaddestass said:

This only works in OBS Studio and ONLY after disabling AA.

Works in my OBS Classic, just streamed with it.

This workaround seems highly unstable, I had to restart DayZ 2-3 times and to play around sources and in OBS before I got a picture. 

Share this post


Link to post
Share on other sites

If you have nvidia card, make sure that the geforce experience is running and turned on, that way you can even use AA in fullscreen mode. It works for me with OBS v0.657b.

Share this post


Link to post
Share on other sites
15 hours ago, Identhun said:

If you have nvidia card, make sure that the geforce experience is running and turned on, that way you can even use AA in fullscreen mode. It works for me with OBS v0.657b.

Doesn't work for me. GeForce Experience is up and running every time I start the game for 6 months already (not in desktop capture mode, tho). OBS 0.656b.

Actually today I've seen a streamer who accidentally turned on AA setting during the stream, and the video feed stopped almost immediately. And that streamer has a very decent Nvidia card and GeForce Experience always running.

Share this post


Link to post
Share on other sites
9 hours ago, CallMeRive said:

Doesn't work for me. GeForce Experience is up and running every time I start the game for 6 months already (not in desktop capture mode, tho). OBS 0.656b.

Actually today I've seen a streamer who accidentally turned on AA setting during the stream, and the video feed stopped almost immediately. And that streamer has a very decent Nvidia card and GeForce Experience always running.

Sure if you mess with the AA while you stream, it will freeze the stream's picture (I made it also). But with Gef.Exp. and turned off AA, it goes well for me.

Share this post


Link to post
Share on other sites

The bug is still here. I really hope it will be fixed before pushing the patch to stable, 'cause this issue (alongside with Shadowplay issue) makes DayZ-related content creation harder than ever.

Share this post


Link to post
Share on other sites

SparkyBoy, I'm talking about "Game capture" option. Not "Monitor capture".

If you stream DayZ, you should know that "Monitor capture" option eats you FPS like crazy. It's very CPU-intensive.

That's why (and considering other reasons) "Game capture" option always has been the best choice for streaming DayZ and many other games.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

  • Similar Content

    • By Gerofied
      Hey all, 
      I've recently been getting back into DayZ, Streaming and recording content for Youtube, 
      Recently have done a series of DayZ moments,
      Let me know what you think 
    • By The Classified Rebel
      On the stable I can choose to go 1920x1080 (16:9) and it would do it on my 1920x1080 (16:10) monitor but now it wont even give me the option to choose that ratio. Now I have black bars on the sides of my stream and if I go to full screen it puts my second monitor black so I can not see any of my other windows. I don't know if this is a bug or if they are only letting you choose the ratio of that monitor, I should be able to choose whatever ratio I want.